Discussion:
Samba und Windows 10
(zu alt für eine Antwort)
Peter Blancke
2016-03-26 09:52:19 UTC
Permalink
Guten Morgen,

hier: Debian/Jessie, Samba 4.1.17 und Windows 10 (Professional, 64
Bit).

Mit unten angefuegter Samba-Konfiguration (nur der Hauptteil, der
Rest ist wohl weniger wichtig) habe ich problemlos Rechner mit
Win-XP (32 Bit) und Windows 7 (Professional 64 Bit) in der Domain
laufen. Die Anmeldung der Rechner klappt einwandfrei.

Samba laeuft laut "testparm" als "Server role: ROLE_DOMAIN_PDC".
Sieht also korrekt aus.

Jetzt ist der erste Windows-10-PC dazugekommen und schon gibt es
Schwierigkeiten:

- Der Domainbeitritt erfolgte problemlos; in der Registry wurden die
beiden erforderlichen Schluessel "DomainCompatibilityMode" und
"DNSNameResolutionRequired" korrekt gesetzt.

- ABER: Ein Anmelden eines Benutzers endet gleich nach
Kennworteingabe mit der Meldung: "Es sind momentan keine
Anmeldeserver zum Verarbeiten der Anmeldeanforderung verfuegbar".

Hier komme ich nicht weiter.

Sofern man nach der Meldung des fehlenden Anmeldeservers sucht,
kommt man im Zusammenhang mit Samba allenfalls zu Hinweisen, der
Domainserver musz "anpingbar" sein. Hier habe ich aber alle Versuche
durch. Bei meiner Domain "BLANCKEDOMAIN" (Hostname
"server.blancke.local") funktionieren "ping blanckedomain", "ping
blanckedomain.blancke.local", ping blanckeserver.blancke.local und
auch "ping server.blancke.local". Mit Ping kann das also irgendwie
nicht zusammenhaengen.

Was wird hier folglich also als "Anmeldeserver" erwartet?

Wo suche ich da weiter? Weisz mir einer Rat?

Grusz,

Peter Blancke


Aus "samba.conf":

[global]
workgroup = BLANCKEDOMAIN
netbios name = Blanckeserver

log file = /var/log/samba/%m
log level = 3
max logsize = 1000
syslog = 0

time server = yes

interfaces = lo eth0
bind interfaces only = yes

; Samba als PDC
domain logons = yes
domain master = yes
local master = yes
preferred master = yes
# logon script = %U.bat
logon script = start.cmd
logon path = \\blanckeserver\profile\%U
logon drive = H:

security = user
encrypt passwords = true

### Experimente
## wins server = 192.168.90.254
--
Hoc est enim verbum meum!
Oliver Doll
2016-04-04 15:34:25 UTC
Permalink
Post by Peter Blancke
- ABER: Ein Anmelden eines Benutzers endet gleich nach
Kennworteingabe mit der Meldung: "Es sind momentan keine
Anmeldeserver zum Verarbeiten der Anmeldeanforderung verfuegbar".
Hier komme ich nicht weiter.
Hilft evt. Folgendes (gleicher Betreff, nur anders sortiert ;) weiter news:DXO$***@helmut.hullen.de
https://wiki.samba.org/index.php/Registry_changes_for_NT4-style_domains#Windows_10:_.E2.80.9ENo_logon_servers_available.E2.80.9C
--
DuG
Oliver

Hoc est enim responsum meum!
Peter Blancke
2016-04-07 11:47:50 UTC
Permalink
Post by Oliver Doll
Post by Peter Blancke
- ABER: Ein Anmelden eines Benutzers endet gleich nach
Kennworteingabe mit der Meldung: "Es sind momentan keine
Anmeldeserver zum Verarbeiten der Anmeldeanforderung verfuegbar".
Hilft evt. Folgendes (gleicher Betreff, nur anders sortiert ;) weiter
https://wiki.samba.org/index.php/Registry_changes_for_NT4-style_domains#Windows_10:_.E2.80.9ENo_logon_servers_available.E2.80.9C
Ja, und zwwar der Eintrag "max protocol = NT1" in die smb.conf.

Leider halbiert (in etwa) das die Uebertragungsgeschwindigkeit im
Netzwerk. Das werden meine Kunden nicht gerne wahrnehmen.

Irgendwie kommt mir das ganze auch sehr merkwuerdig vor, dasz mit
Win7 Dinge gehen, die unter Win10 nur unter Ausbremsung der
Protokolle weiterexistieren.

Ich suche gerade, ob es so etwas gibt wie "min protokol" und "max
protocol". Meine Vorstellung ist, dasz sich Win7 sein schnelles
Protokoll waehlt und Win10 gerne auf das "NT1" schaltet, wenn es das
meint.

Das Problem ist zwar geloest, aber es stellt nicht zufrieden.

Danke fuer Deinen Hinweis.

Grusz,

Peter Blancke
--
Hoc est enim verbum meum!
Loading...