Discussion:
Samba in Lubuntu reagiert nicht
(zu alt für eine Antwort)
Andreas Kohlbach
2019-08-06 21:10:05 UTC
Permalink
Hallo Leute,
Hallo Ilja (auch wenn es "Hallo Freunde war"). ;-)
Ein frisch mit Lubuntu 18 LTS 64-bit eingerichteter Rechner sieht
weder Windows Rechner im Netzwerk noch den Samba Share eines bereits
mit Linux eingerichteten Laptop (alle Windows Rechner sehen den und
umgekehrt). Samba ist installiert.
Damals bei der Umstellung des ersten Rechners brachte Nautilus nach
vielen Fehlschlaegen den Durchbruch, die Einrichtung ging damit
ratzfatz. Diesmal nicht. Beim letzten Einschalten zeigte Nautilus zwar
noch ein Windows Netzwerk an, ergab aber beim Kick nur eine
Fehlermeldung. Jetzt wird ueberhaupt kein Windows Netzwerk mehr
angezeigt, ich kann daher nichts einrichten und auch die recht
kryptische Fehlermeldung zwecks Log nicht wiederbekommen.
Weiss jemand, was "Failed to create /var/log/samba/cores for user 1000
with mode 0700" nach dem Aufruf von nmbd bedeutet? Im Web fand ich
nichts dazu.
Ich würde vermuten, dass diese für root (oder dem User "samba) erstellt
werden sollten, die nicht die ID 1000 (die ist in der Regel die Deines
ersten erstellten Nicht-Root-Users, vermutlich Du selbst) haben. Root
sollte die ID 0 haben. "sambashare" hat hier 128, was in jedem System
aber anders sein mag.
Failed to create /var/log/samba/cores for user 1000 with mode 0700
Unable to setup corepath for nmbd: No such file or directory
[2019/08/05 14:55:23.073597, 0]
../lib/util/debug.c:1053(reopen_logs_internal)
Unable to open new log file '/var/log/samba/log.': Permission denied
Es handelt sich um ein jungfraeuliches unbenutztes Lubuntu, beim dem
ich lediglich Nautilus und Samba nachgeladen habe.
Hast Du systemd? Versuche stattdessen

systemctl start smbd
systemctl start nmbd

Ich leite nach de.comp.os.unix.networking.samba weiter, wo die Experten sind.
--
Andreas
Herrand Petrowitsch
2019-08-07 10:00:45 UTC
Permalink
Post by Andreas Kohlbach
Ein frisch mit Lubuntu 18 LTS 64-bit eingerichteter Rechner sieht
weder Windows Rechner im Netzwerk noch den Samba Share eines bereits
mit Linux eingerichteten Laptop (alle Windows Rechner sehen den und
umgekehrt). Samba ist installiert.
Damals bei der Umstellung des ersten Rechners brachte Nautilus nach
vielen Fehlschlaegen den Durchbruch, die Einrichtung ging damit
ratzfatz. Diesmal nicht. Beim letzten Einschalten zeigte Nautilus zwar
noch ein Windows Netzwerk an, ergab aber beim Kick nur eine
Fehlermeldung. Jetzt wird ueberhaupt kein Windows Netzwerk mehr
angezeigt,
Hat sich bereits jemand mit der Frage des Protokolls befasst? In Windows
wird SmbV1 standardmaessig nicht mehr unterstuetzt, s.a.

<https://support.microsoft.com/de-de/help/2696547/detect-enable-disable-smbv1-smbv2-smbv3-in-windows-and-windows-server>
<https://support.microsoft.com/de-de/help/4034314/smbv1-is-not-installed-by-default-in-windows>
<https://www.borncity.com/blog/2018/08/27/smbv1-faq-und-windows-netzwerke/>
<https://www.borncity.com/blog/2019/07/11/samba-4-11-deaktiviert-smbv1-und-untersttzt-smbv2/>

[...]
Post by Andreas Kohlbach
Ich leite nach de.comp.os.unix.networking.samba weiter, wo die Experten sind.
Gruss Herrand
--
Emails an die angegebene Adresse werden gelegentlich sogar gelesen.
Loading...